5 Changes in Cisco Unified Communications Manager (CUCM) Version 12.0

If you’re one of the 200,000+ Cisco customers using a Cisco Unified Communications Manager (CUCM) server to support your Cisco IP Phones and soft clients, this blog post is for you. Specifically, Cisco recently introduced their latest version of CUCM, version 12.0, and this post will identify a five of the major changes in this new version.

1. Support for Hybrid Deployments

For the past year or so, I’ve been getting questions from people concerned that CUCM is going away, and that Cisco Unified Communication (UC) customers will gravitate towards Cisco’s cloud-based call management solution, called Cisco Hosted Collaboration Solution (HCS). To get some answers, at Cisco Live US earlier this year, I asked one of the Cisco UC engineers about their plans. He assured me that Cisco is committed to going forward with both solutions (i.e. their cloud-based solution and their on-premises CUCM solution). He also explained customers don’t have to choose one or the other, because both the cloud-based and locally hosted solutions can communicate and work together in a hybrid deployment. CUCM 12.0 supports this hybrid design approach, which lets you have fewer SIP trunks going out to your service provider, because calls within your location are being handled locally by your CUCM server.

2. Unsupported IP Phone Models

Before upgrading to CUCM 12.0, you might have to replace some (and potentially many) of your Cisco IP Phones. The following Cisco IP Phone models are not supported in CUCM 12.0 (and many of the following are not supported in CUCM 11.5 either):

  • 7970G
  • 7971G-GE
  • 7921G
  • 12 SP+
  • 30 VIP
  • 7902
  • 7905
  • 7910
  • 7910SW
  • 7912
  • 7920
  • 7935

3. Smart Software Licensing

CUCM 12.0 doesn’t use the traditional Product-Activation Key (PAK) for licensing. Instead, it relies on Cisco’s new approach to licensing, called Smart Software Licensing, where your licenses are associated with your Cisco account, rather than the specific device being licensed.

4. IPv6-Only Support

Although it’s not a requirement, CUCM 12.0 allows you to have an all-IPv6 deployment.

5. Enforcement of Minimum TLS Version

Perhaps you have a security policy that requires a minimum version of Transport Layer Security (TLS) be used between your UC devices. CUCM 12.0 allows you to specify the minimum TLS version to be used. TLS 1.0 is configured by default, but you can change that minimum to version 1.1 or 1.2.

Lots More Features

Of course, CUCM 12.0 introduces lots of other new features and updates. For a comprehensive discussion on all things new with CUCM 12.0, click HERE

Kevin Wallace, CCIEx2 (R/S and Collaboration) #7945

Close

50% Complete

Two Step

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.